Apple, новият Mac OS X 10.6, Microsoft и Windows XP

Последните вечери бяха интересни … от събота съм започнал да преинсталирам всичко на голямата машина. Под всичко, имам предвид – ВСИЧКО :).Много нерви бяха, в крайна сметка всичко работи както трябва, в момента. Dual-boot Windows и Mac OS X 10.6.1, през на windows boot menu-то, чрез boot0 файлче.

0. 2 твърди диска – 320gb SATA и 80gb IDE (през JMicron интерфейс), дъно P5B, Core 2 Duo 4400 @ 2 gGHz. BIOS-a в AHCI режим, че иначе не става.
1. Бакъпнах всичко (180 gb) на USB hdd от приятел
2. Преформатирах харддиска, разделен на 4, GUID partition. Първия – за windows, втория за snow, третия за storage, четвъртия – 10 гб за инсталацията (макар, че не разбрах защо трябва да restore-вам dmg-то там и да инсталирам от там … нищо не променях по файловете).
3. Инсталирах под Leopard на втория партишън 10.6, ресторнах всички файлове от бакъпа през това време, някви кекстове, абе квото пишеха по поста от който инсталирах (вече не помня кой беше).
4. Някак успях да заредя 10.6. Всичко уж наред, ама се крашваше през 1-2-3 минути. 64-битов режим … явно не е за мен :). така, хубу, 32-битов. Малко ядове докато тръгне (копирах разни кекстове и тествах, според разни форуми), но в крайна сметка тръгна без да забие. И то ДОСТА стабилно (още не е забивал).
5. Така, уж всичко наред, като гледам, видео, звук, wifi, всичко тръгна на 6.
6. Ред на бозата. Имах някво изо на някъв виндовс със SP3 (леле, да не забравя да го изтрия и да wipe-на 35 пъти(tm) празното място), съответно инсталирам на 320-ката, обаче … боза, не ще да се инсталира, омазана работа, син екран. Чак накрая усетих, че е от AHCI-то, ама късно – инсталирах го на 80-ката вече (затривайки Leoparda, който се подвизаваше там по това време, отрязвайки си достъпа до някаква читава ОС под която да фиксвам). Такааа, виндовс тръгна. Обаче. МНОГО орязано дистро, НИЩО нямаше, ама нищо, дори драйверите за запис по диска. Wireless-а дропеше през 1 минута някъде. Решение – ще го сменям. Добре ама не ми работи запис на дискове … а трябва да запиша друго ISO 🙂 забавно нали 🙂
7. Разрових се за дискове на XP. Намерих 4 диска в ателието затрупани с 1000 вида linux дистрибуции. Добре, втория запали. Инсталирах наново, всичко ИЗГЛЕЖДА наред 🙂 даже не забива. интересно, трябва да видя защо … както и да е, сега ще буутвам snow! хаха, стига толкоз М$.
8. Даааааа ама не. boot0 упорито даваше грешки, не иска и не иска. Нищо не намира. Хммм, чета форуми.
9. След много четене (не станах по-умен) установих, че явно смотания windows ми е направи партишъна на windows неактивен. Точно така се оказа. Заредих Hiren Boot CD 9.9 … обаче ударих на камък. Понеже е GUID и програмите мислят че е счупено … хм.
10. Пак форуми. Този път пуснах няква вградена боза на windows-а за редактиране на партишъни (май diskpart се казваше, но се постарах максимално бързо да я забравя :)). Чрез нея и следвайки едно мини-howto, успях да го направя активен партишъна на OSX.
11. Успех! (донякъде). Chameleon-а буутва. OS-X-а забива. Едно пускане с -v показа, че не може да намери дяла с някво си UUID. Ох … пак ФОРУМИ!. След още четене (май ставам по-тъп, вместо по-умен…) разбрах, че мога да заредя с rd=disk0s3 параметър.
12. Йееее! Зареди!!! Голям кеф(тм).
13. Момент … нещо не е в час. Disk Utility не ми дава проверка на диска, както и някви странни данни дава. Хммм, форуми?
14. Не ми трябваха форуми а едно пускане на fdisk под конзола за да установя проблема. Мамка му и Windows (че кой друг да е?). Партишъна на OS X от тип HFS+ станал на NTFS … ГРРРРРРРРррр!
15. Бърз boot от Hiren, няква мини програмка за редактиране на partitions, смених 07(май) на AF, рестарт и … РАБОТИИИИИ!!!
16. Добре, всичко е наред този път, няма изненади, гадости и т.н. Сега, трябва да направя така, че или Windows да тръгне с AHCI, или Mac OS X да тръгне под IDE режим. Първото беше за предпочитане, така че се помъчих подобаващо 2 часа с това. НЕ стана. Т.е. стана, донякъде. Драйвера на Intel за матрикс сторидж нещо си (тоя за AHCI) упорито твърдеше, че не съм бил имал минимума за инсталация. Кьорих се, място има, процесор, памет, XP SP3, не знам кво му липсваше. Четох форуми, затъпях още повече. Нищо не стана, всякакви идеи пробвах, нъц. Писна ми, заредих OS X, добавих 2 кекста, restart, BIOS, AHCI=>IDE, restart, OS X – работи. Restart, Windows – работи. Менюто за избор на OS – работи. Phew, този път май стана.

Равносметката: 2 цели дена и 1 вечер пропиляни. Мен ако питате, Windows не ви трябва, за съжаление, жена ми е свикнала. Кофти навици, трябва да я отуча някой ден 🙂

4 мнения по „Apple, новият Mac OS X 10.6, Microsoft и Windows XP

  1. Peerless

    Еми така е, да беше питал да ти кажа…
    Това си е най-нормалното нещо, вин-а да скапе боот партишъна след инстал 🙂

  2. wasp Автор

    бе да бе ама … омазана работа 🙂 карай де, важното е, че тръгна. А 14-та точка как ще ми я обясниш? 🙂

Вашият коментар

Вашият имейл адрес няма да бъде публикуван. Задължителните полета са отбелязани с *